57

After upgrading the SDK to Azure Cloud Service Diagnostic 2.6, all the WAD trace logs started to look like this:

EventName="FormattedMessageEvent" FormattedMessage="Subscription {0} Already Created" Argument0="sub2feature-staging" TraceSource="w3wp.exe"

Previously it use to just write out "Subscription sub2feature-staging Already Created" TraceSource="w3wp.exe"

Is this something I can configure? Also looks like a lot of messages has moved from information to verbose.

It's probably a combination of my log provider and some changes done in Azure Cloud Service Diagnostic 2.6.

4
  • I noticed the same thing, and I've started to look at switching to ETW EventSource derived classes for Azure logging, although I'm currently having issues with the custom WADMyEvent tables not always showing up. May 13, 2015 at 3:07
  • Do share any information in this processs. Might be something the rest of us azure devs can use. May 13, 2015 at 7:17
  • Everything worked after I upgraded to .NET 4.5.1 from .NET 4.5.0 (which was silently failing to create the WAD event table when I had 4 arguments). See my new answer to an old Stackoverflow question I had for example of using ETW Event Source: stackoverflow.com/questions/18899185/… May 13, 2015 at 15:00
  • You should switch to ETW tracing. That is the future and the way to go
    – Frank Q.
    May 13, 2016 at 4:29

1 Answer 1

0

I know this is old, but since it is unanswered, it is a great way to test knowledge.

https://docs.microsoft.com/en-us/previous-versions/azure/reference/dn479282(v=azure.100)#azure-sdk-release-dates-retirement-dates-and-support-information

If you goto that link you will see the supported version of .net are 4.5.2, 4.6*, 4.6.1* So it is possible 4.5.1 could work but not be supported.

That would answer why updating your framework fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.