0

After attempting to install strongloop, It threw a few warnings and errors.

Command used to install was: npm install -g strongloop

Errors:

c:\users\yoel\.node-gyp\4.2.4\include\node\v8.h(336): error C2988: unrecognizable template declaration/definition [C:\Users\Yoel\AppData\Roaming\npm\node_modules\strongloop\node_modules\heapdump\build\addon.vcxproj]
c:\users\yoel\.node-gyp\4.2.4\include\node\v8.h(336): error C2059: syntax error : 'using' [C:\Users\Yoel\AppData\Roaming\npm\node_modules\strongloop\node_modules\heapdump\build\addon.vcxproj]
c:\users\yoel\.node-gyp\4.2.4\include\node\v8.h(576): error C2061: syntax error : identifier 'WeakCallbackType' [C:\Users\Yoel\AppData\Roaming\npm\node_modules\strongloop\node_mododules\heapdump\build\addon.vcxproj]
c:\users\yoel\.node-gyp\4.2.4\include\node\v8.h(915): error C2989: 'v8::HandleScope' : class template has already been declared as a non-class template [C:\Users\Yoel\AppData\Roaming\npm\node_modules\strongloop\node_modules\heapdump\build\addon.vcxproj]
.
.
. 

etc... [many of the same errors and a few others]

This is the error log form builderror.log :

gyp ERR! build error 
gyp ERR! stack Error: `msbuild` failed with exit code: 1
gyp ERR! stack     at ChildProcess.onExit (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\build.js:270:23)
gyp ERR! stack     at emitTwo (events.js:87:13)
gyp ERR! stack     at ChildProcess.emit (events.js:172:7)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild"
gyp ERR! cwd C:\Users\Yoel\AppData\Roaming\npm\node_modules\strongloop\node_modules\node-inspector\node_modules\ws
gyp ERR! node -v v4.2.4
gyp ERR! node-gyp -v v3.0.3
gyp ERR! not ok 

I am using Node 4.2.4, Python 2.7.11 and NPM 2.14.12

Things I've tried:

  • reinstalling gyp
  • reinstalling visual studio 2012
  • installing strongloop with visual studio 2015
  • installing strongloop with visual studio 2013
  • installing strongloop with visual studio 2010

Any ideas? anyone else encountered a similar issue?

Note: I am able to run slc, but I have no way of knowing if everything works properly. It's not like a warning I can just ignore.

4
  • 1
    Try updating your version of Node-gyp npm install -g node-gyp
    – JSimonsen
    Jan 20, 2016 at 18:01
  • 1
    @bladefist are you sure the installation as a whole is failing? The error messages are for components that should be optional and shouldn't cause the installation to fail. Jan 21, 2016 at 5:22
  • @RyanGraham it sounds like you're right. but it's strange to have so many C compiling errors in an important component such as gyp. It looks like node-gyp is installed correctly now.
    – bladefist
    Jan 22, 2016 at 0:48
  • Ya, it's unfortunate that Windows isn't as easy to develop and test on for module authors. The result is a lot of the popular modules with native addons don't build properly on Windows. The good news is a lot of them are optional and have pure JS fallbacks. Jan 22, 2016 at 6:18

1 Answer 1

0

This has resolved the issue.

Step 1:
reinstall node-gyp to latest version: npm install -g node-gyp

Step 2:
run strongloop installation again like so: npm install -g strongloop --msvs_version=2012

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.