33

I am stucked for a month with video example given in Qt Video Overview.

I tried that code, but only I get is blank square (QWidget). I am using GStreamer0.10 for media playback over Qt5. I also played video with gst-launch-0.10 command and it works okay, but I cannot determine what's happening in Qt and why it won't work?

I looked in error log of X Server, located in /etc/X11/Xorg.0.log, and when I use fbdev as a display driver configured in /etc/X11/xorg.conf it shows me the error:

"FBDEV(0): FBIOPUTCMAP: Invalid argument"

when I use modesetting driver everything acts the same but no errors. I figured out that when I delete xorg.conf file and start X server again, video works but with lack of colors and with flickering also example works well on my Ubuntu VM and via vnc client. Every advice and help will be appreciated.

  • Target machine: BeagleBone Black

  • Distribution: Debian Jessie 8.2

  • Kernel Version: 4.1.15-ti-rt-r43

List of available drivers in /usr/lib/xorg/modules/drivers: ati_drv.so, mach64_drv.so, nouveau_drv.so, r128_drv.so, vesa_drv.so, fbdev_drv.so, modesetting_drv.so, omap_drv.so, radeon_drv.so

Here is a full error log from Xorg when I try to launch my Qt application on BeagleBone Black under Debian Jessie 8.2 -> http://pastebin.com/4x8KztBk

xorg.conf file from /etc/X11 -> http://pastebin.com/4WhX8pJc

11
  • If you just need a mediaplayer, qt-vlc might be better.
    – Zen
    Mar 14, 2016 at 11:15
  • @Thomas I will post everything you need, just say.
    – user5585984
    Mar 16, 2016 at 10:29
  • I posted update @Thomas
    – user5585984
    Mar 16, 2016 at 10:35
  • Maybe this can help you? doc.qt.io/qt-5/qwidget.html#native-widgets-vs-alien-widgets
    – arrowd
    Mar 16, 2016 at 10:55
  • @arrowd I tried export QT_USE_NATIVE_WINDOWS=1, but the same behavior.
    – user5585984
    Mar 16, 2016 at 10:56

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy